$re = '/(^[^\|]*)\|/m';
$str = 'usr/bin/pipe|pipe|name|28|-rwxr-xr-x|root:root||46711b361edd4512814d9b367ae765f42a71d729708b3f2e162acb8f64592610|
';
$subst = "$1###";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;