const regex = /(^[^\|]*)\|/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[^\\|]*)\\|', 'gm')
const str = `usr/bin/pipe|pipe|name|28|-rwxr-xr-x|root:root||46711b361edd4512814d9b367ae765f42a71d729708b3f2e162acb8f64592610|
`;
const subst = `$1###`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);