using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"2\d{3}-(0[1-9]|1[0-2])-(0[1-9]|[1,2][0-9]|3[0,1])";
string input = @"mano data yra tokia:L 2014-11-22 areba 2013-09-23. Va tiek.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}