$re = '/^.*\/?packs\/(.*)$/m';
$str = 'packs/aldkfjasldk234234k;asjd
splash.popgun.ai/packs/aldkfjasldk234234k;asjd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);