re = /^.*\/?packs\/(.*)$/m
str = 'packs/aldkfjasldk234234k;asjd
splash.popgun.ai/packs/aldkfjasldk234234k;asjd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end