import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d\\W+)(h\\.?s\\.?\\s+)?a\\s+m\\b";
final String string = "5 a m\n"
+ "5: a m\n"
+ "5: hs a m\n"
+ "5: h.s. a m\n"
+ "5: h.s a m\n"
+ "5: hs. a m\n"
+ "5: a m\n"
+ "5 : hs a m\n"
+ "5 : h.s. a m\n"
+ "5 : h.s a m\n"
+ "5 : hs. a m\n"
+ "5 hs a m\n"
+ "5 h.s. a m\n"
+ "5 h.s a m\n"
+ "5 hs. a m\n"
+ "Cerca de las 2: hs a m, hay que salir antes de esas hs a m\n"
+ "A medida que avance cerca de la media noche 12: 04 hs a m. Deben ir a las 15 hs a m.\n"
+ "A mmm... cerca de las 12: h.s a m, hay que salir antes de esas h.s. a m\n"
+ "A medida que avance cerca de las 12:04 hs. a m. Deben ir alas 15 h.s a m.";
final String subst = "\\1\\2am";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}