const regex = new RegExp('(\\d\\W+)(h\\.?s\\.?\\s+)?a\\s+m\\b', 'gm')
const str = `5 a m
5: a m
5: hs a m
5: h.s. a m
5: h.s a m
5: hs. a m
5: a m
5 : hs a m
5 : h.s. a m
5 : h.s a m
5 : hs. a m
5 hs a m
5 h.s. a m
5 h.s a m
5 hs. a m
Cerca de las 2: hs a m, hay que salir antes de esas hs a m
A medida que avance cerca de la media noche 12: 04 hs a m. Deben ir a las 15 hs a m.
A mmm... cerca de las 12: h.s a m, hay que salir antes de esas h.s. a m
A medida que avance cerca de las 12:04 hs. a m. Deben ir alas 15 h.s a m.`;
const subst = `\1\2am`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);