import re
regex = re.compile(r"(\d\W+)(h\.?s\.?\s+)?a\s+m\b", flags=re.MULTILINE)
test_str = ("5 a m\n"
"5: a m\n"
"5: hs a m\n"
"5: h.s. a m\n"
"5: h.s a m\n"
"5: hs. a m\n"
"5: a m\n"
"5 : hs a m\n"
"5 : h.s. a m\n"
"5 : h.s a m\n"
"5 : hs. a m\n"
"5 hs a m\n"
"5 h.s. a m\n"
"5 h.s a m\n"
"5 hs. a m\n"
"Cerca de las 2: hs a m, hay que salir antes de esas hs a m\n"
"A medida que avance cerca de la media noche 12: 04 hs a m. Deben ir a las 15 hs a m.\n"
"A mmm... cerca de las 12: h.s a m, hay que salir antes de esas h.s. a m\n"
"A medida que avance cerca de las 12:04 hs. a m. Deben ir alas 15 h.s a m.")
subst = "\\1\\2am"
result = regex.sub(subst, test_str)
if result:
print(result)