using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+\/inference="".+\n[^\/\n]+\n[^\/\n]?\n?\s+\/codon_start=.+";
string input = @" /inference=""similar
dfg
/codon_start=ds
/inference=""similar
/codon_start=ds";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}