$re = '/\s+\/inference=".+\n[^\/\n]+\n[^\/\n]?\n?\s+\/codon_start=.+/';
$str = ' /inference="similar
dfg
/codon_start=ds
/inference="similar
/codon_start=ds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);