const regex = /\s+\/inference=".+\n[^\/\n]+\n[^\/\n]?\n?\s+\/codon_start=.+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+\\\/inference=".+\\n[^\\\/\\n]+\\n[^\\\/\\n]?\\n?\\s+\\\/codon_start=.+', 'g')
const str = ` /inference="similar
dfg
/codon_start=ds
/inference="similar
/codon_start=ds`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}