# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?!^)\G|^[^@])[^@](?=[^@]+@)/$1*/g;t' <<< "example@gmail.com"