using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?!^)\G|^[^@])[^@](?=[^@]+@)";
string substitution = @"$1*";
string input = @"example@gmail.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}