use strict;
my $str = 'example@gmail.com';
my $regex = qr/((?!^)\G|^[^@])[^@](?=[^@]+@)/p;
my $subst = '$1*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";