$re = '/^[0-9]{10,13}$/m';
$str = '0084966713061
84966713061
0966713061
123456
abdfaksdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);