re = /^[0-9]{10,13}$/m
str = '0084966713061
84966713061
0966713061
123456
abdfaksdf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end