using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?sm)\A.*?(?=message)";
string input = @"package grpc;
import ""envoyproxy/protoc-gen-validate/validate/validate.proto"";
import ""google/api/annotations.proto"";
import ""google/protobuf/wrappers.proto"";
import ""protoc-gen-swagger/options/annotations.proto"";
message Acc {
message AccErr {
enum Enum {
UNKNOWN = 0;
CASH = 1;
}
}
string account_id = 1;
string name = 3;
string account_type = 4;
}
message Name {
string firstname = 1;
string lastname = 2;
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}