import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sm)\\A.*?(?=message)";
final String string = "package grpc;\n\n"
+ "import \"envoyproxy/protoc-gen-validate/validate/validate.proto\";\n"
+ "import \"google/api/annotations.proto\";\n"
+ "import \"google/protobuf/wrappers.proto\";\n"
+ "import \"protoc-gen-swagger/options/annotations.proto\";\n\n"
+ "message Acc {\n"
+ " message AccErr {\n"
+ " enum Enum {\n"
+ " UNKNOWN = 0;\n"
+ " CASH = 1;\n"
+ " }\n"
+ " }\n"
+ " string account_id = 1;\n"
+ " string name = 3;\n"
+ " string account_type = 4;\n"
+ "}\n\n"
+ "message Name {\n"
+ " string firstname = 1;\n"
+ " string lastname = 2;\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}