import re
regex = re.compile(r"(?sm)\A.*?(?=message)", flags=re.MULTILINE)
test_str = ("package grpc;\n\n"
"import \"envoyproxy/protoc-gen-validate/validate/validate.proto\";\n"
"import \"google/api/annotations.proto\";\n"
"import \"google/protobuf/wrappers.proto\";\n"
"import \"protoc-gen-swagger/options/annotations.proto\";\n\n"
"message Acc {\n"
" message AccErr {\n"
" enum Enum {\n"
" UNKNOWN = 0;\n"
" CASH = 1;\n"
" }\n"
" }\n"
" string account_id = 1;\n"
" string name = 3;\n"
" string account_type = 4;\n"
"}\n\n"
"message Name {\n"
" string firstname = 1;\n"
" string lastname = 2;\n"
"}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")