using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0(,\d{0,2})?|-?[1-9]\d*(,\d{1,2})?|-0,(0[1-9]|[1-9]\d?))$";
string input = @"Deverá aceitar:
0
0,
0,0
0,00
0,010
0,00000000000000000000002
0,01
0,99
0,1
1234567890,99
-1234567890,99
-0,01
-0,99
1,00
-1,00
-1,012
Não poderá aceitar:
-0
-0,
-0,00
-,01 a -,99
//Sequencia vazio
01,00
01
0012";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}