// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(0(,\d{0,2})?|-?[1-9]\d*(,\d{1,2})?|-0,(0[1-9]|[1-9]\d?))$").unwrap();
let string = "Deverá aceitar:
0
0,
0,0
0,00
0,010
0,00000000000000000000002
0,01
0,99
0,1
1234567890,99
-1234567890,99
-0,01
-0,99
1,00
-1,00
-1,012
Não poderá aceitar:
-0
-0,
-0,00
-,01 a -,99
//Sequencia vazio
01,00
01
0012";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}