const regex = /^(0(,\d{0,2})?|-?[1-9]\d*(,\d{1,2})?|-0,(0[1-9]|[1-9]\d?))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0(,\\d{0,2})?|-?[1-9]\\d*(,\\d{1,2})?|-0,(0[1-9]|[1-9]\\d?))$', 'gm')
const str = `Deverá aceitar:
0
0,
0,0
0,00
0,010
0,00000000000000000000002
0,01
0,99
0,1
1234567890,99
-1234567890,99
-0,01
-0,99
1,00
-1,00
-1,012
Não poderá aceitar:
-0
-0,
-0,00
-,01 a -,99
//Sequencia vazio
01,00
01
0012`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}