#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(https?:\/\/).*(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2})\.){3}(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2}))"
Local $sString = "http://test.com/" & @CRLF & _
"http://1.2.3.4/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")