package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?:\/\/).*(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2})\.){3}(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2}))`)
var str = `http://test.com/
http://1.2.3.4/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}