re = /(https?:\/\/).*(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2})\.){3}(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2}))/
str = 'http://test.com/
http://1.2.3.4/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end