#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[+-]?\b[1-9][0-9]*\b"
Local $sString = "-90" & @CRLF & _
"90" & @CRLF & _
"-0" & @CRLF & _
"-00" & @CRLF & _
"1" & @CRLF & _
"-1" & @CRLF & _
"0" & @CRLF & _
"00" & @CRLF & _
"+2 This is a test 2 and -10 with 0 and +10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")