$re = '/[+-]?\b[1-9][0-9]*\b/m';
$str = '-90
90
-0
-00
1
-1
0
00
+2 This is a test 2 and -10 with 0 and +10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);