using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!.*email).)*thank(\-|\_|)you.*";
string input = @"http://www.safesteptub.com/thank-you
http://www.safesteptub.com/email/thank-you/
NOTE:
Newlines are excluded as well. Please make sure the string you want to test is at the top of the list.
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}