const regex = /^((?!.*email).)*thank(\-|\_|)you.*/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!.*email).)*thank(\\-|\\_|)you.*', 'gi')
const str = `http://www.safesteptub.com/thank-you
http://www.safesteptub.com/email/thank-you/
NOTE:
Newlines are excluded as well. Please make sure the string you want to test is at the top of the list.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}