const regex = /^([^|]*)\|0\|?(\d[^|]*)\|([^|]*)\|([^|]*)\|([^|]*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^|]*)\\|0\\|?(\\d[^|]*)\\|([^|]*)\\|([^|]*)\\|([^|]*)$', '')
const str = `WISEMAN·CINDY|0|29.98|THE·OZARK·FOOD·COOPERATIVE·EXCHANGE|9/30/2013·UT04·‐·Capital·Credit·Distributions|20464721`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}