use strict;
my $str = 'WISEMAN·CINDY|0|29.98|THE·OZARK·FOOD·COOPERATIVE·EXCHANGE|9/30/2013·UT04·‐·Capital·Credit·Distributions|20464721';
my $regex = qr/^([^|]*)\|0\|?(\d[^|]*)\|([^|]*)\|([^|]*)\|([^|]*)$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}