using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/[^\r\n]+/(?>([imus])(?!.*?\1))*+$";
string substitution = @"_";
string input = @"/[^/]\s+(a|b) \/\\[^cde]\p{Cyrillic}[^>]*(?<!\/)/imus";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}