package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[A-Za-z0-9 ]*[a-zA-Z ][0-9]*)*$`)
var str = `lorem ipsum
lorem ipsum 123
123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}