$re = '/^(?:[A-Za-z0-9 ]*[a-zA-Z ][0-9]*)*$/m';
$str = 'lorem ipsum
lorem ipsum 123
123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);