re = /^(?:[A-Za-z0-9 ]*[a-zA-Z ][0-9]*)*$/m
str = 'lorem ipsum
lorem ipsum 123
123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end