using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]+[.][0-9]{2}$";
string input = @"Good Examples..
234234.00
2342342.12
234.11
2.22
3.33
Bad Examples
3242.1
2342
3.1
.22";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}