const regex = /^[0-9]+[.][0-9]{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]+[.][0-9]{2}$', 'gm')
const str = `Good Examples..
234234.00
2342342.12
234.11
2.22
3.33
Bad Examples
3242.1
2342
3.1
.22`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}