import re
regex = re.compile(r"^[0-9]+[.][0-9]{2}$", flags=re.MULTILINE)
test_str = ("Good Examples..\n\n"
"234234.00\n"
"2342342.12\n"
"234.11\n"
"2.22\n"
"3.33\n"
"Bad Examples\n\n"
"3242.1\n"
"2342\n"
"3.1\n"
".22")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")