package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Fa-f{64}]`)
var str = `6e8bf00e05ed6877dd9ce04b2d93a8d00261db7de1bac5ac744b2e92219485ad`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}