import Foundation
let pattern = #"[A-Fa-f{64}]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"6e8bf00e05ed6877dd9ce04b2d93a8d00261db7de1bac5ac744b2e92219485ad"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}