#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "WebSphere Application Server|HTTPServer"
Local $sString = "Initiating status for all WAS services in this order (as nodeagent ihs dmgr)..." & @CRLF & _
"Initiating status for application servers..." & @CRLF & _
"WebSphere Application Server - jmsserver1 is running (57218)." & @CRLF & _
"WebSphere Application Server - server1 is running (53698)." & @CRLF & _
"WebSphere Application Server - server2 is running (40662)." & @CRLF & _
"Initiating status for nodeagent..." & @CRLF & _
"WebSphere Application Server - nodeagent is running (14232)." & @CRLF & _
"Initiating status for IHS http server..." & @CRLF & _
"HTTPServer is running." & @CRLF & _
"Initiating status for deployment manager..." & @CRLF & _
"WebSphere Application Server - dmgr is running (33175)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")