import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "WebSphere Application Server|HTTPServer";
final String string = "Initiating status for all WAS services in this order (as nodeagent ihs dmgr)...\n"
+ "Initiating status for application servers...\n"
+ "WebSphere Application Server - jmsserver1 is running (57218).\n"
+ "WebSphere Application Server - server1 is running (53698).\n"
+ "WebSphere Application Server - server2 is running (40662).\n"
+ "Initiating status for nodeagent...\n"
+ "WebSphere Application Server - nodeagent is running (14232).\n"
+ "Initiating status for IHS http server...\n"
+ "HTTPServer is running.\n"
+ "Initiating status for deployment manager...\n"
+ "WebSphere Application Server - dmgr is running (33175).";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}