use strict;
my $str = 'Initiating status for all WAS services in this order (as nodeagent ihs dmgr)...
Initiating status for application servers...
WebSphere Application Server - jmsserver1 is running (57218).
WebSphere Application Server - server1 is running (53698).
WebSphere Application Server - server2 is running (40662).
Initiating status for nodeagent...
WebSphere Application Server - nodeagent is running (14232).
Initiating status for IHS http server...
HTTPServer is running.
Initiating status for deployment manager...
WebSphere Application Server - dmgr is running (33175).';
my $regex = qr/WebSphere Application Server|HTTPServer/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}