using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*Server";
string input = @"Initiating status for all WAS services in this order (as nodeagent ihs dmgr)...
Initiating status for application servers...
WebSphere Application Server - jmsserver1 is running (57218).
WebSphere Application Server - server1 is running (53698).
WebSphere Application Server - server2 is running (40662).
Initiating status for nodeagent...
WebSphere Application Server - nodeagent is running (14232).
Initiating status for IHS http server...
HTTPServer is running.
Initiating status for deployment manager...
WebSphere Application Server - dmgr is running (33175).";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}