# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*Server"
test_str = ("Initiating status for all WAS services in this order (as nodeagent ihs dmgr)...\n"
"Initiating status for application servers...\n"
"WebSphere Application Server - jmsserver1 is running (57218).\n"
"WebSphere Application Server - server1 is running (53698).\n"
"WebSphere Application Server - server2 is running (40662).\n"
"Initiating status for nodeagent...\n"
"WebSphere Application Server - nodeagent is running (14232).\n"
"Initiating status for IHS http server...\n"
"HTTPServer is running.\n"
"Initiating status for deployment manager...\n"
"WebSphere Application Server - dmgr is running (33175).")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.