package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*Server`)
var str = `Initiating status for all WAS services in this order (as nodeagent ihs dmgr)...
Initiating status for application servers...
WebSphere Application Server - jmsserver1 is running (57218).
WebSphere Application Server - server1 is running (53698).
WebSphere Application Server - server2 is running (40662).
Initiating status for nodeagent...
WebSphere Application Server - nodeagent is running (14232).
Initiating status for IHS http server...
HTTPServer is running.
Initiating status for deployment manager...
WebSphere Application Server - dmgr is running (33175).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}