#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!^(CON|PRN|AUX|NUL|COM[1-9]|LPT[1-9])$)[^\x00-\x1F<>:\"\/\\|?*]*[^\x00-\x1F<>:\"\/\\|?*. ]$"
Local $sString = "hallo men name ist bernd.txt" & @CRLF & _
"< (less than)" & @CRLF & _
"> (greater than).txt." & @CRLF & _
"(greater-than).txt" & @CRLF & _
"(greater-than).txt." & @CRLF & _
": (colon - sometimes works, but is actually NTFS Alternate Data Streams)" & @CRLF & _
"" (double quote)" & @CRLF & _
"/ (forward slash)" & @CRLF & _
"\ (backslash)" & @CRLF & _
"| (vertical bar or pipe)" & @CRLF & _
"? (question mark)" & @CRLF & _
"Loldusche (Lécuseß Adalb@mmals).jpeg" & @CRLF & _
"* (asterisk)" & @CRLF & _
"esel-ekay.txt" & @CRLF & _
"CON" & @CRLF & _
"CON, PRN, AUX, NUL " & @CRLF & _
"CON, PRN, AUX, NUL" & @CRLF & _
"COM1" & @CRLF & _
"COM2, COM3, COM4, COM5, COM6, COM7, COM8, COM9" & @CRLF & _
"LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, LPT9" & @CRLF & _
"LPT1" & @CRLF & _
"LPTx" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")