# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!^(CON|PRN|AUX|NUL|COM[1-9]|LPT[1-9])$)[^\x00-\x1F<>:\"\/\\|?*]*[^\x00-\x1F<>:\"\/\\|?*. ]$"
test_str = ("hallo men name ist bernd.txt\n"
"< (less than)\n"
"> (greater than).txt.\n"
"(greater-than).txt\n"
"(greater-than).txt.\n"
": (colon - sometimes works, but is actually NTFS Alternate Data Streams)\n"
"\" (double quote)\n"
"/ (forward slash)\n"
"\\ (backslash)\n"
"| (vertical bar or pipe)\n"
"? (question mark)\n"
"Loldusche (Lécuseß Adalb@mmals).jpeg\n"
"* (asterisk)\n"
"esel-ekay.txt\n"
"CON\n"
"CON, PRN, AUX, NUL \n"
"CON, PRN, AUX, NUL\n"
"COM1\n"
"COM2, COM3, COM4, COM5, COM6, COM7, COM8, COM9\n"
"LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, LPT9\n"
"LPT1\n"
"LPTx\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.