import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!^(CON|PRN|AUX|NUL|COM[1-9]|LPT[1-9])$)[^\\x00-\\x1F<>:\\\"\\/\\\\|?*]*[^\\x00-\\x1F<>:\\\"\\/\\\\|?*. ]$";
final String string = "hallo men name ist bernd.txt\n"
+ "< (less than)\n"
+ "> (greater than).txt.\n"
+ "(greater-than).txt\n"
+ "(greater-than).txt.\n"
+ ": (colon - sometimes works, but is actually NTFS Alternate Data Streams)\n"
+ "\" (double quote)\n"
+ "/ (forward slash)\n"
+ "\\ (backslash)\n"
+ "| (vertical bar or pipe)\n"
+ "? (question mark)\n"
+ "Loldusche (Lécuseß Adalb@mmals).jpeg\n"
+ "* (asterisk)\n"
+ "esel-ekay.txt\n"
+ "CON\n"
+ "CON, PRN, AUX, NUL \n"
+ "CON, PRN, AUX, NUL\n"
+ "COM1\n"
+ "COM2, COM3, COM4, COM5, COM6, COM7, COM8, COM9\n"
+ "LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, LPT9\n"
+ "LPT1\n"
+ "LPTx\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}