import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^<para styleclass=\"Table Row Heading Text\">)(?:[^<]*)(<.*)(?=<\\/para>)";
final String string = "<para styleclass=\"Table Row Heading Text\">some text<text style=\"font-size:12pt;\">iso.outgoingQueueNameas</text></para>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}